Kia EV6 Forum banner
1 - 20 of 34 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Hi all,

Wondering if anyone has a hack that might fix this.

We have not been able to get AC operating regularly. I've tried all combinations, and it actually has worked randomly a few times which is the most frustrating thing (so I feel confident that there is enough coolant). I've enabled/disabled all the climate options (the AC dehumidifier, etc), and nothing. Also have tried with/without auto mode (and recirculation on/off, etcc etc).

Anyways, just curious if anyone else has run into this and has any good fixes. My dealer has hedged on having any service people with much experience on the EV6, so that's a little frustrating.

I don't think the first wave of US version cars has a software update yet either, so that's the only other thing I can think of at the moment
 

·
Registered
Joined
·
158 Posts
One of the few features that I don't like and causes confusion is the infotainment/climate switch to change modes.

Triangle Font Parallel Circle Diagram


Then use use the switch on the knob to think you are operating the radio or the A/C.

Font Terrestrial plant Circle Auto part Multimedia


You might send off an email to Kia Customer Assistance. They do answer on occasion.

What kind of of climate conditions are you in?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 · (Edited)
We're in the Carolinas, so it's just starting to get warmer. The fact that I did indeed felt the familiar "bite" of AC going (when the car interior heated up in the sun for a while on a 70 degree day) is the frustrating part, it's just hard to reproduce whatever I did to get it working. Also frustrating were those few times where I know it was working, parking/turning off the car for the night with no changes, and then going back to not working the next day with no user change, etc..

Say Watt, yeah I am familiar with the control switch, I've gotten used to that paradigm. Well anyways, I guess I'll just need to time this for warm days when the dealer can believe me.
 

·
Registered
Joined
·
158 Posts
I checked with a friend who does A/C work and he said check for a water puddle under the car. That would mean the evaporator is freezing up and preventing air flow The car won’t cool properly until the ice melts. Also, the drain could be plugged or the system undercharged or overcharged. The dealer should be able to diagnose the A/C system since it’s the same as in an ICE vehicle (ironic acronym).

The car electronics is another universe. Maybe try another dealer that isn’t afraid to triage with the factory.
 

·
Registered
Joined
·
3 Posts
Hi all,

Wondering if anyone has a hack that might fix this.

We have not been able to get AC operating regularly. I've tried all combinations, and it actually has worked randomly a few times which is the most frustrating thing (so I feel confident that there is enough coolant). I've enabled/disabled all the climate options (the AC dehumidifier, etc), and nothing. Also have tried with/without auto mode (and recirculation on/off, etcc etc).

Anyways, just curious if anyone else has run into this and has any good fixes. My dealer has hedged on having any service people with much experience on the EV6, so that's a little frustrating.

I don't think the first wave of US version cars has a software update yet either, so that's the only other thing I can think of at the moment
My AC hasn’t been working for several weeks. Brought it in and after about a week the Service department and Techline determined I have a bad PTC HEATER. They ordered a new one and I am awaiting arrival
 

·
Registered
Joined
·
373 Posts
My guess would be the PTC HEATER is randomly turning on thus creating heat and dissipating the cold air into cool air
to add some color to this, my AC is now dead and it definitely doesn’t follow that theory. My compressor doesn’t come on at all now, under any circumstances. Heat works fine though.
 

·
Registered
Joined
·
22 Posts
to add some color to this, my AC is now dead and it definitely doesn’t follow that theory. My compressor doesn’t come on at all now, under any circumstances. Heat works fine though.
About the same here: I just bought my EV6 a couple of days ago.

It was 85 degrees today, and will be 95 tomorrow. There's no cold air blowing out of the vents. When running the AC on maximum, the energy usage for "Climate" is 0.0kw.

At night (when it's less than 82 degrees...) I can set the heat up to 82, and see the Climate energy usage climb up to about 1.7ish kW. So something is working.... just not air conditioning.
 

·
Registered
Joined
·
373 Posts
I did notice while testing my system with car scanner that the battery was clearly rapidly pulsing 5kW or so, while the energy display was only showing 1.3 or so. I think that’s an indication that the PTC is getting PWMed, because my compressor was dead as a doornail.

only thing left to do is bring it in for repairs, but I’m not hopeful they actually understand the problem yet.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #13 · (Edited)
Kind of maddening, after 2 weeks of not being able to get cold air on hotter days, it started working today out of nowhere (no changes to any settings, just turned on the AC button with sync, and voila...). So frustrating, I have to keep setting new dealer appointments to try to time a warmer day and they will be clueless
 

·
Registered
Joined
·
373 Posts
Kind of maddening, after 2 weeks of not being able to get cold air on hotter days, it started working today out of nowhere (no changes to any settings, just turned on the AC button with sync, and voila...). So frustrating, I have to keep setting new dealer appointments to try to time a warmer day and they will be clueless
Man, that's... upsetting. I've just noticed something very interesting. Comparing my engine bay (motor bay?) to Munro Live's Ioniq 5, also with AWD and heat pump, theirs has two coolant loops, red and blue, where ours has only one, red. I wonder if Kia tried to get clever simplifying the cooling system VS Hyundai's, and whiffed on the execution.
 

·
Registered
Joined
·
1 Posts
About the same here: I just bought my EV6 a couple of days ago.

It was 85 degrees today, and will be 95 tomorrow. There's no cold air blowing out of the vents. When running the AC on maximum, the energy usage for "Climate" is 0.0kw.

At night (when it's less than 82 degrees...) I can set the heat up to 82, and see the Climate energy usage climb up to about 1.7ish kW. So something is working.... just not air conditioning.
I have had my EV6 for 3 weeks. The AC broke 3 days ago and has been at the dealership for 2 days. They said a piece broke and that is what’s causing the problem. I was told that they can’t order the part until Kia engineering okays it as these are new vehicles…..I’m extremely frustrated. I really expected better for such an expensive vehicle.
 

·
Registered
Joined
·
22 Posts
About the same here: I just bought my EV6 a couple of days ago.

It was 85 degrees today, and will be 95 tomorrow. There's no cold air blowing out of the vents. When running the AC on maximum, the energy usage for "Climate" is 0.0kw.
FWIW: The dealership sold me a new car with no refrigerant in it.
One of the Schrader valves was leaking -- a quick replacement, a slow refill, and AC is working great!

Based on some of the horror stories, I'm glad mine was a quick fix.
 
1 - 20 of 34 Posts
Top