Kia EV6 Forum banner
1 - 20 of 66 Posts

Registered
Joined
2 Posts
Discussion Starter · #1 ·
I had my first big road in my EV6 but had problems trying to get heat into the cabin, ideally setup heating to 22 and left on Auto but as the night got colder so did the cabin, ramping temperature up made no difference cool air just kept coming out....in hindsight I was mostly in Eco mode would this have made a difference I was at the point of wanting gloves on 馃榿
 

Registered
EV6 77kWh RWD Steel Grey (05/22)
Joined
73 Posts
I had my first big road in my EV6 but had problems trying to get heat into the cabin, ideally setup heating to 22 and left on Auto but as the night got colder so did the cabin, ramping temperature up made no difference cool air just kept coming out....in hindsight I was mostly in Eco mode would this have made a difference I was at the point of wanting gloves on 馃榿
Is this still an issue?
 

Registered
2022 Kia EV6 First Edition Steel Gray Matte
Joined
293 Posts
I had my first big road in my EV6 but had problems trying to get heat into the cabin, ideally setup heating to 22 and left on Auto but as the night got colder so did the cabin, ramping temperature up made no difference cool air just kept coming out....in hindsight I was mostly in Eco mode would this have made a difference I was at the point of wanting gloves on 馃榿
Check the system settings. I believe that there is an option to limit climate system for range.
 

Registered
Joined
1 Posts
I had my first big road in my EV6 but had problems trying to get heat into the cabin, ideally setup heating to 22 and left on Auto but as the night got colder so did the cabin, ramping temperature up made no difference cool air just kept coming out....in hindsight I was mostly in Eco mode would this have made a difference I was at the point of wanting gloves on 馃榿
We have the same problem. Did you find a solution?
 

Registered
Joined
50 Posts
It is working now. I think the problem is the uvo app. I tried to activate it by the app and after a couple a minutes I get an error. I deleted everything and stopped the climate control in the app. Now it is working so far.
 

Registered
Joined
1 Posts
Hi, anyone got a solid solution for this problem? I was driving for ca 180km and during the trip (-1C) the car only gave the cabin cold air for about 30 min, and the the heat came back. Heat button was on.
 

Registered
Joined
15 Posts
Hi, anyone got a solid solution for this problem? I was driving for ca 180km and during the trip (-1C) the car only gave the cabin cold air for about 30 min, and the the heat came back. Heat button was on.
Same problem here. Heating is unreliable in the EV6. Can't trust it, which is a big concern in winter in Sweden. This morning, could not leave home because I could not get heat on the frosted windshield.

Also haven't been able to pre-heat the car through KIA Connect and UVO.

Contaced KIA this morning as I have the car for 5 days now. Will report a solution here when I know more. Seems like a software related issue, I would say.
 

Registered
Joined
15 Posts
According to this review, Kia is aware of the issue and is working on it. Translated from Polish:
Any news about the solution? Just now returned from a 80 km trip without any heat in -1. I now use a 230 V 2000W external heater on the back seat as a back-up. Had to use it all the time. Contacted KIA and hopefully they can look at it tomorrow. They told me I'm currently the only one reporting this problem in Sweden. However on this forum I see more people reporting the same issue.

Gesture Automotive lighting Automotive design Finger Bumper
 

Registered
Joined
40 Posts
Any news about the solution? Just now returned from a 80 km trip without any heat in -1. I now use a 230 V 2000W external heater on the back seat as a back-up. Had to use it all the time. Contacted KIA and hopefully they can look at it tomorrow. They told me I'm currently the only one reporting this problem in Sweden. However on this forum I see more people reporting the same issue.
They told me I'm the only one reporting this in Spain too. They opened a ticket to Kia hotline support (I don't know if that service is national or international).
I told them there are more EV6 having this issue in other countries but I'm not sure if they are talking to each other.
I just had a phone call today saying the think they will get news about by Friday.

As soon as I get any info on this I will post it here.
 

Registered
Joined
10 Posts
I had the lack of heat problem too and was due to take it to Kia tomorrow. I updated the firmware this morning and have gone on a long drive and have had it nice and toasty. I have held off on taking it in tomorrow but will check over the next week.
I have also been able to start the ACC remotely from the app when the car is plugged in and not charging, when it's plugged in and charging and when it's not plugged in.
Before the update the language kept changing to French, it hasn't since.

The only potential issue I have left is that if you use the auto setting of the ACC it doesn't seem to put the AC on and the car steams up but pressing the AC clears it.

Hope this helps.
 

Registered
Joined
50 Posts
I had the lack of heat problem too and was due to take it to Kia tomorrow. I updated the firmware this morning and have gone on a long drive and have had it nice and toasty. I have held off on taking it in tomorrow but will check over the next week.
I have also been able to start the ACC remotely from the app when the car is plugged in and not charging, when it's plugged in and charging and when it's not plugged in.
Before the update the language kept changing to French, it hasn't since.

The only potential issue I have left is that if you use the auto setting of the ACC it doesn't seem to put the AC on and the car steams up but pressing the AC clears it.

Hope this helps.
Updated the firmware, you mean the nav system with the update from 12 Nov?
 

Registered
Joined
15 Posts
I had the lack of heat problem too and was due to take it to Kia tomorrow. I updated the firmware this morning and have gone on a long drive and have had it nice and toasty. I have held off on taking it in tomorrow but will check over the next week.
I have also been able to start the ACC remotely from the app when the car is plugged in and not charging, when it's plugged in and charging and when it's not plugged in.
Before the update the language kept changing to French, it hasn't since.

The only potential issue I have left is that if you use the auto setting of the ACC it doesn't seem to put the AC on and the car steams up but pressing the AC clears it.

Hope this helps.
Updating EV6 firmware sounds like a solution that could work. Could you share how you did it in your EV6? Willing to try right now, as I'm also about to take it back to KIA tomorrow.
 

Registered
Joined
205 Posts
I had the lack of heat problem too and was due to take it to Kia tomorrow. I updated the firmware this morning and have gone on a long drive and have had it nice and toasty. I have held off on taking it in tomorrow but will check over the next week.
I have also been able to start the ACC remotely from the app when the car is plugged in and not charging, when it's plugged in and charging and when it's not plugged in.
Before the update the language kept changing to French, it hasn't since.

The only potential issue I have left is that if you use the auto setting of the ACC it doesn't seem to put the AC on and the car steams up but pressing the AC clears it.

Hope this helps.
Do you mean the Infotainment Software update? I was not aware we either could get, nor use firmware updates? And what is ACC please?
 
1 - 20 of 66 Posts
Top