Kia EV6 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
I've just been told by my dealer they have performed an 'ECU update' to fix the 'non starting issue' following a technical bulletin

I hope it is an actual fix and they just haven't actually just rebooted it again.
 

·
Registered
Joined
·
81 Posts
I've just been told by my dealer they have performed an 'ECU update' to fix the 'non starting issue' following a technical bulletin

I hope it is an actual fix and they just haven't actually just rebooted it again.
Did they mention a ‘traction control’ update?
Had mine in yesterday for the heating update and they just mentioned you are scheduled for another update without saying what it was.
When I asked they just said ‘traction control’

Not heard of this on the forum at all so wondering was it the update you have mentioned and they were just fobbing me off 🤷🏼‍♂️
 

·
Super Moderator
Joined
·
540 Posts
I've just been told by my dealer they have performed an 'ECU update' to fix the 'non starting issue' following a technical bulletin

I hope it is an actual fix and they just haven't actually just rebooted it again.
Will be good to see if you can get it to do the Zombie issue when you get it back to confirm the update worked.
 

·
Registered
Joined
·
17 Posts
The "traction control" issue is a false positive on the ESP, I had it a couple of times, the ESP kicks in, the orange esp icon flashes, the car slowdown than accelerate (a bit like empty tank hiccup but far less pronounced, very perceptible especially on cruise control on motorway). also suspends line control. Stopping and resetting the car solves the problem.

"Zombie mode": workaround: reset works (no more waiting time). Keep the standyby/power button in for more than 10 seconds, then turn car off/on again. It solved it for me everytime. Still a long term fix would be a lot better.

Other issue: Following 10 seconds reset (above), had a really strange behavior of the head unit triggering the "you are driving in the wrong direction" (that you should get when getting on motorway through exit - I had it triggered once in road work that moved the motorway) constantly (even for non-motorway). Had to reset head unit with pen.

Did they mention a ‘traction control’ update?
Had mine in yesterday for the heating update and they just mentioned you are scheduled for another update without saying what it was.
When I asked they just said ‘traction control’

Not heard of this on the forum at all so wondering was it the update you have mentioned and they were just fobbing me off 🤷🏼‍♂️
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #5 ·
In answer to the questions:

Yes they did the ABS/Traction update too - they referred to it as ABS - but when queried they said 'and traction control'

The zombie mode isn't always fixed by the 10 second hold reset - it does most times - but twice (including once when the dealer had it) it needed switching off, locking and waiting 10 minutes.

Having said that after the last reset it went two weeks without the issue - so it's going to be a while before we know whether it really worked.
 

·
Registered
Joined
·
17 Posts
Yes "zombie mode" seems to like buses, you wait for ages and then they keep coming.
At first I took it to the dealer for inspection (as I had twice in the 2 days after getting delivery.... end of october) and they said it already had all the upgrade and they couldn't find anything. I was a bit dubious about the "we did nothing" but it disappeared, but only for a few weeks. Since it is relatively frequent.

I'm wondering if zombie and HVAC/Inverter issues are not related and zombie being a result of the inverter not working, draining the 12v battery.


In answer to the questions:

Yes they did the ABS/Traction update too - they referred to it as ABS - but when queried they said 'and traction control'

The zombie mode isn't always fixed by the 10 second hold reset - it does most times - but twice (including once when the dealer had it) it needed switching off, locking and waiting 10 minutes.

Having said that after the last reset it went two weeks without the issue - so it's going to be a while before we know whether it really worked.
 

·
Registered
Joined
·
297 Posts
Did they mention a ‘traction control’ update?
Had mine in yesterday for the heating update and they just mentioned you are scheduled for another update without saying what it was.
When I asked they just said ‘traction control’

Not heard of this on the forum at all so wondering was it the update you have mentioned and they were just fobbing me off 🤷🏼‍♂️
I had the traction control update done at the same time I had the heating update last week. Did not notice any problem on the traction control.
 
1 - 7 of 7 Posts
Top