Kia EV6 Forum banner
1 - 20 of 98 Posts

·
Registered
EV6 Wind AWD w/Tech Package
Joined
·
113 Posts
Discussion Starter · #1 ·
Got the error message and brought it to the dealer. Kia requested I leave it and they tried to put me in a rental but enterprise is out of vehicles, so I'm without a car. Anyone else have this error?
 

·
Registered
Joined
·
16 Posts
Got the error message and brought it to the dealer. Kia requested I leave it and they tried to put me in a rental but enterprise is out of vehicles, so I'm without a car. Anyone else have this error?
I do. My 1st edition EV6 displayed the dreaded "Check Electric Vehicle System" on the 2nd day I drove it. Took it to the dealer almost 6 weeks ago, they ran every test under the sun w/o resolution. The KIA Regional Tech engineer will come check it out this week. I was lucky to get a Sorento as loaner. I also have a case opened with KIA Consumer Affairs. I'll keep you posted.
 

·
Registered
EV6 Wind AWD w/Tech Package
Joined
·
113 Posts
Discussion Starter · #3 ·
I do. My 1st edition EV6 displayed the dreaded "Check Electric Vehicle System" on the 2nd day I drove it. Took it to the dealer almost 6 weeks ago, they ran every test under the sun w/o resolution. The KIA Regional Tech engineer will come check it out this week. I was lucky to get a Sorento as loaner. I also have a case opened with KIA Consumer Affairs. I'll keep you posted.
Yep I have a case with kia consumer affairs too. Also have them looking into lemon law stuff soon its looking like it may be >30 days in the shop.

Did you get your DTC code?
 

·
Registered
EV6 Wind AWD w/Tech Package
Joined
·
113 Posts
Discussion Starter · #5 ·
2 and counting, not good. I wonder if it is a USA version problem only?
To be fair, we don't know if their issue is the same since we don't know the DTC. If it was, I doubt the regional tech engineer would be coming out.

But I will say, I'm definitely not the first with a 3-way valve issue.
 

·
Registered
Joined
·
16 Posts
Yep I have a case with kia consumer affairs too. Also have them looking into lemon law stuff soon its looking like it may be >30 days in the shop.

Did you get your DTC code?
No I haven't. If any code was thrown during all the testing I haven't been informed. Funny thing, when I mentioned the lemon law to the service guy he acted like he never heard about it. Anyway I told him that, at that moment, that was not my intention. I waited 9 months for my unit and was willing to give them all the time they need to fix it. If it was another run-of-mill vehicle I would've a contacted a lawyer by now. I'm all in with my EV6; I love it how it drives and I can see myself cruising around town after this nightmare passes and see peoples' faces when I park it next to them and commenting on how nice it looks. If you love yours as much as I do mine, be patient! I hope that the KIA expert finds what's wrong quickly using the update that came out last week and that if a part is needed I don't have to wait months to get it. I heard that having a case opened helps a lot with that regard. Good luck and keep in touch.
 

·
Registered
Joined
·
16 Posts
Yes. Mine in shop for over a week. And they have no idea what’s the problem.
According to KIA Consumer Affairs, BTW open a case with them if you haven't done so, I was the only one with that problem. I can see now I'm not. I hope they monitor this forum and see they might have a bigger problem than are willing to accept. I wish whoever reads this thread and has the problem joins in and report it. "In unity there is strength"
 

·
Registered
Joined
·
6 Posts
No I haven't. If any code was thrown during all the testing I haven't been informed. Funny thing, when I mentioned the lemon law to the service guy he acted like he never heard about it. Anyway I told him that, at that moment, that was not my intention. I waited 9 months for my unit and was willing to give them all the time they need to fix it. If it was another run-of-mill vehicle I would've a contacted a lawyer by now. I'm all in with my EV6; I love it how it drives and I can see myself cruising around town after this nightmare passes and see peoples' faces when I park it next to them and commenting on how nice it looks. If you love yours as much as I do mine, be patient! I hope that the KIA expert finds what's wrong quickly using the update that came out last week and that if a part is needed I don't have to wait months to get it. I heard that having a case opened helps a lot with that regard. Good luck and keep in touch.
I have had a case open from day omen as well. And funny thing I just received the error message again on my Kia connect app. Yet they tried to send the car home with me on Saturday and I said not without knowing what’s wrong. They had cleared the code and could not get it to repeat. Well glad I left it because it happened again last night at midnight.
 

·
Registered
Joined
·
16 Posts
After almost 3 weeks of waiting the KIA Tech guru showed up as scheduled today. I can see movement via the KIA Access app; doors show "unlocked" (nothing happened during the waiting period). I'm keeping my fingers crossed hoping he really knows his stuff.
 

·
Registered
Joined
·
6 Posts
I have been informed someone is coming this week for my car as well. It did throw the error code again. Which I am happy so hoping they can figure this out. I miss my car. Fingers crossed. Curious to hear what they diagnosis your issue as. Good luck.
 

·
Registered
EV6 Wind AWD w/Tech Package
Joined
·
113 Posts
Discussion Starter · #12 ·
I have been informed someone is coming this week for my car as well. It did throw the error code again. Which I am happy so hoping they can figure this out. I miss my car. Fingers crossed. Curious to hear what they diagnosis your issue as. Good luck.
Ask them what the DTC shows. If it's the same as mine, it's likely in need of a new 3-way valve. Mine hopefully will be in the beginning of next week.
 

·
Registered
Joined
·
16 Posts
Good news: tech found out the A/C compressor had a short causing the error. :)
Bad news: part was ordered Yesterday w/o any ETA. :(
Also, he didn't know about the firmware update. Looked in the computer and found 2 pending which he promised will be applied.
 

·
Registered
2016 Ford Edge Ti
Joined
·
276 Posts
I expect that it is to early to know, but just in case. Does anyone know for sure what the failure mode is for this 3 way valve? Is it an electrical module failure, a mechanical valve failure, or a combination of the two or maybe something else entirely?
 

·
Registered
Joined
·
6 Posts
As I reported in another thread, when I went to inspect my car (maybe my car - I have not technically taken delivery) after an amp replacement because the audio system did not work after the sa494 update, it was displaying the "check electric vehicle system" error. Did you get the U112800 information from a code reader or did you get this detail some other way?

Good luck with your issue - I'm not sure how to proceed with mine.
 

·
Registered
EV6 Wind AWD w/Tech Package
Joined
·
113 Posts
Discussion Starter · #17 · (Edited)
As I reported in another thread, when I went to inspect my car (maybe my car - I have not technically taken delivery) after an amp replacement because the audio system did not work after the sa494 update, it was displaying the "check electric vehicle system" error. Did you get the U112800 information from a code reader or did you get this detail some other way?

Good luck with your issue - I'm not sure how to proceed with mine.
The dealership had it on a printout but a code reader would tell you too.
 
1 - 20 of 98 Posts
Top