Kia EV6 Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
The USB A I use for Android Auto suddenly stopped working properly... but...

  • The LED of/around the USB port still works
  • It still charges my Galaxy Buds case
  • The phone with the same cable does connect to other devices, like my PC for example.
  • I also filled a USB stick with a few songs to see if it would read it > nope

Has anyone else also experienced this?
 

·
Registered
KIA EV6 AWD Wind w/Tech Package
Joined
·
112 Posts
The USB A I use for Android Auto suddenly stopped working properly... but...

  • The LED of/around the USB port still works
  • It still charges my Galaxy Buds case
  • The phone with the same cable does connect to other devices, like my PC for example.
  • I also filled a USB stick with a few songs to see if it would read it > nope

Has anyone else also experienced this?
Do you have another cable to try just to eliminate that completely in this car?
 

·
Registered
Joined
·
25 Posts
Mine does this sometimes - just refuses to play nice with the USB port - tried all sorts of cables and replugging but the only thing that solves it is turning the car off - getting out - locking it - then booting everything up again
 

·
Registered
Joined
·
121 Posts
Had this happen to me yesterday, first time since I bought it 2.5 months ago. @theatomiclizard’s solution apparently worked for me, although I wasn’t aware of it…
 

·
Registered
Joined
·
1 Posts
The USB A I use for Android Auto suddenly stopped working properly... but...

  • The LED of/around the USB port still works
  • It still charges my Galaxy Buds case
  • The phone with the same cable does connect to other devices, like my PC for example.
  • I also filled a USB stick with a few songs to see if it would read it > nope

Has anyone else also experienced this?
Yes, and dealer has no idea what to do. Apparently there is only one port available so they cant rerun an update asfaik. Seems that they need to replace parts until it starts working. We manage it to charge an smaller Samsung Phone. But Galaxy S20 and usb memory will not work.
 

·
Registered
Joined
·
121 Posts
I’ve had this happen twice. Both times I had also gotten a recent 12v battery warning. In both cases, after a couple of hours it started working again.
Happened to me today. This is the second time in about a month. In retrospect, I do think the full reboot is the key. I’ll try the paper clip next time.
 

·
Registered
Joined
·
2 Posts
Yes, and dealer has no idea what to do. Apparently there is only one port available so they cant rerun an update asfaik. Seems that they need to replace parts until it starts working. We manage it to charge an smaller Samsung Phone. But Galaxy S20 and usb memory will not work.
Just got the car back again. They replaced the usba and still not working. I asked them to redo latest update but they need to wait for Kias input. Actually as I was suspecting the updates is done thru OBD, so my usba has probably never worked.
 

·
Registered
KIA EV6 Wind AWD Glacier White
Joined
·
195 Posts
It happened to me once. I have a USB stick with music plugged in. Drove to Home Depot with the music on. When I left the USB was not working. Stopped the car and started it again and was still not working. Next day it was working again.
 
1 - 11 of 11 Posts
Top