Kia EV6 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi Everyone,

My car is expected to get delivered in 2 days and I just received a call from dealer and they are telling me that the car's infotainment is booting 3-5 minutes after the car starts, the dashboard screen works fine, and after the infotainment screen boots it works fine as well. They told me they couldn't find a solution yet, has anyone gone through this before?

Regards
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #2 ·
Update, at the time the car was delivered to me the infotainment screen was not working at all, I am still able to use the car and luckily I have access to seek button to search for radio stations but that is about it when it comes to features. The dealership has informed me that they ordered a new screen but no delivery date is coming in, looks like it could be weeks and months. But how come I cannot get a certain or even estimated date for delivery from a established automaker like KIA, when I can get it pretty accurately from anywhere else, that is another question.
 

·
Registered
Nov 21 EV6 GT Line RWD in yacht blue.
Joined
·
21 Posts
That's quite a serious issue and I would consider rejecting the car if they cannot sort this really quickly. Could they swap of from one of their demonstrators until your part arrives?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
I had to accept the car, as it had to be delivered before 2022, so that I can enjoy a lower tax on the car in NL, but I don't think they would ever change the problematic part with one of their demo versions, I am not even sure if they know how to replace it in the first place as it is a new car, but I wrote an semi angry email to head of service and head of branch they haven't replied in the past few days. I guess it is what it is and all we can do is wait..
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Update, while driving the car out of blue infotainment system turns on, I park the car, start playing with the system and everything works perfectly, I was able to pair kia connect and setup carplay, then out of blue screen goes black again... wtf... at least now I can use remote features of the car and if I plug my phone i can listen through carplay.. so the thing works but for some reason screen is not turning on properly, most probably a soldering issue. In the meantime 2 months and no news from the dealer on the arrival of the new module...
 

·
Registered
Joined
·
11 Posts
Hi Everyone,

My car is expected to get delivered in 2 days and I just received a call from dealer and they are telling me that the car's infotainment is booting 3-5 minutes after the car starts, the dashboard screen works fine, and after the infotainment screen boots it works fine as well. They told me they couldn't find a solution yet, has anyone gone through this before?

Regards
I am having problems with mine. None of the functions work. I am going to deman that the infotainment system be replaced aif it cannot be repaired.
 

·
Registered
Snow White Pearl GT-Line AWD
Joined
·
1,495 Posts
I am having problems with mine. None of the functions work. I am going to deman that the infotainment system be replaced aif it cannot be repaired.
Did you try doing a reset by using the reset button? Its the tiny pinhole located next tot he volume/temp knob.
 
1 - 10 of 10 Posts
Top