Kia EV6 Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter · #1 ·
KIA Connect
I have been having charging and pre heat problems with my EV6. Initially I could not get the car to do a scheduled charge.
It worked on the first night, but I have had problems since. I also cannot get the car to do a pre heat unless the car is currently charging.
I have been back to the dealer, tried various things including different charging cables, but have not been able to get the car to Pre Heat. The dealer has logged a call with KIA. Since my visit to the dealers I have not needed to charge the car, I did try last night as the battery was down to 48%.
The original problem occurred again where the car goes to immediate charge. I tried all sorts with the app but was unable to get the car to do a Scheduled charge. To cancel out the peak rate charge I had to select ‘stop charging’ on the app.
My off peak electric is 00:30 - 04:30. At 00:35, I checked but scheduled charging had not started. I tried various things but could not get the car to start charging, so I gave up and went to bed, as I put my phone on charge, I got a notification from Connect that charging has started at 01:04. When I awoke this morning, I checked my phone, charging finished at 04:41! This is outside the scheduled times set in Connect and is on the peak rate.
I did a refresh on the app to check things over, the new range is showing 230mile but the battery was still showing 48%. I went to the car which shows 230miles on 79% battery. The app still showed only 48% charge, despite many refreshes. I rebooted m phone to see if anything had been frozen, now the status screen shows no data!
Whilst the car is great the KIA Connect app is absolute RUBBISH! I emailed my dealer to advise him of the problems and I suggested dumping Connect and trying UVO, he agreed.
Who else is having problems with KIA Connect?
 

·
Registered
White RWD Long Range w/o Heat Pump
Joined
·
90 Posts
KIA Connect
I have been having charging and pre heat problems with my EV6. Initially I could not get the car to do a scheduled charge.
It worked on the first night, but I have had problems since. I also cannot get the car to do a pre heat unless the car is currently charging.
I have been back to the dealer, tried various things including different charging cables, but have not been able to get the car to Pre Heat. The dealer has logged a call with KIA. Since my visit to the dealers I have not needed to charge the car, I did try last night as the battery was down to 48%.
The original problem occurred again where the car goes to immediate charge. I tried all sorts with the app but was unable to get the car to do a Scheduled charge. To cancel out the peak rate charge I had to select ‘stop charging’ on the app.
My off peak electric is 00:30 - 04:30. At 00:35, I checked but scheduled charging had not started. I tried various things but could not get the car to start charging, so I gave up and went to bed, as I put my phone on charge, I got a notification from Connect that charging has started at 01:04. When I awoke this morning, I checked my phone, charging finished at 04:41! This is outside the scheduled times set in Connect and is on the peak rate.
I did a refresh on the app to check things over, the new range is showing 230mile but the battery was still showing 48%. I went to the car which shows 230miles on 79% battery. The app still showed only 48% charge, despite many refreshes. I rebooted m phone to see if anything had been frozen, now the status screen shows no data!
Whilst the car is great the KIA Connect app is absolute RUBBISH! I emailed my dealer to advise him of the problems and I suggested dumping Connect and trying UVO, he agreed.
Who else is having problems with KIA Connect?
I'm having kind of the same problem but I can't even preheat, plugged or unplugged.
When I start the climate control in Kia Connect next to my EV6 I can hear some mechanic kind of a switch sound, but no air sound. And after that when I get in the car and start, there's no heat in the climate system.
I think there's something wrong with the app.

I don't recommend you to switch to UVO. I did it today and bricked my EV6 until I got back to Kia Connect and started climate control which by the way doesn't work.

I'm quite annoyed with the heat and a/c buttons. I only get heat with both active. If I have only Heat active I get like a minute of heat and then cold. Is anyone having the same problem?
 

·
Registered
White RWD Long Range w/o Heat Pump
Joined
·
90 Posts
Yeb, same here
Hi Liemburg.

Yesterday I did something that has made my EV6 climate system work properly. I think all problems with heating come from the app that activates something in the car making it not work properly.

I just turned on the car with the climate off and sent the turn off climate control command from the app. Waitef till the app said the car received the command. Then restarted the EV6.
Now there's heat coming from my Ev6 whenever I want it.

The only issues now in my case are pre-heating and scheduled charging, and as I said, I think is related to the app.

Please tell me if you try this and help in your case.
 

·
Registered
Joined
·
66 Posts
Thx. I will try this. I my case rhe heating is, working when ik start the car and just drive it and only change the temperature. When I use the blowers it is going wrong after I stop the blower. I wii let yoy know of it is working fine after I ues the app to switch it off
 

·
Registered
White RWD Long Range w/o Heat Pump
Joined
·
90 Posts
Is there anyone here with this weird numbers of consumption in the app?
Is there a workaraund? I contacted support via app and the sent me to the customer support form. Sent two time and nothing...
Product Font Material property Screenshot Magenta
 

·
Registered
Joined
·
166 Posts
I have managed to use 177Kwh since yesterday, 234Km and charged only once.

Yup, app not really there yet.

(The car itself reports 24Kwh/100Km which is a lot. Winter here now and I drove in "Normal". I hope those numbers go way down when I start caring about it.)
 

·
Registered
EV6 GTL AWD Heat pump
Joined
·
48 Posts
Yes using kia connect, very disappointed, despite asking & being assured 5 weeks ago on delivery that latest software had been installed I checked today & its not. I have software & firmware dated 21 07 19, & have ordered a 64gb USB pen drive to download latest software dated 22 04 05. This promises wireless updates from early summer 2022 with maps & software updated twice yearly. It promises wireless update is free for one year but to continue you need to extend Kia Connect subscription. I thought you get Kia Connect for 7 years or is there a higher level of subscription you need for free maps & software update?
 

·
Registered
Joined
·
76 Posts
I had the same on my car.Asked for all the updates.My dealer said that the firmware updates had been done.I have my doubts.My Infotainment says 21/7/19 too.The dealer also hadn't heard of the "fix" for the zombie mode either.
 
1 - 19 of 19 Posts
Top