Kia EV6 Forum banner
1 - 11 of 11 Posts

Registered
Joined
1 Posts
Discussion Starter · #1 ·
Hi
I got my EV6 RWD long range Yacht Blue on the 17 December and so far I satisfied with my new car, apart from a few things.
The HDA (highway driving assist) is zig zagging on the highway, it's not stable at all.
I'm I the only one that have problems with the the Pre-Heating using the 'Start Climate Control' on the KIA Connect?
When I press the button it accept [Success] Climate Control Activated, but 2 min after I get [Alarm] Climate control not available, the car is not pre heated, but even worse
when I start the car the heating is not working at all! until I turn the car completely off and the on again then the heating is working.

/knud
 

Registered
Joined
49 Posts
I'm still waiting the delivery of my EV6. But just the same when reading about your troubles:eek: It's a bit unsettling, what you're telling. Didn't your dealer update the your car before delivery? Those troubles, beside the HDA, should be solved, according to KIA馃
 

Registered
Kia EV6 - RWD 77,4kW - Runway Red
Joined
15 Posts
I got my RWD EV6 a week before christmas, and so far without any problems.
Comments; the HDA problem, I guess might be updated via software, but not sure. Pre-heating via KIA connect i have not seen that. Do you have the latest version of software, othervise go to your dealer, and let them fix your issues.
BTW welcome to the forum. :)
 

Registered
Joined
381 Posts
Hi
I got my EV6 RWD long range Yacht Blue on the 17 December and so far I satisfied with my new car, apart from a few things.
The HDA (highway driving assist) is zig zagging on the highway, it's not stable at all.
I'm I the only one that have problems with the the Pre-Heating using the 'Start Climate Control' on the KIA Connect?
When I press the button it accept [Success] Climate Control Activated, but 2 min after I get [Alarm] Climate control not available, the car is not pre heated, but even worse
when I start the car the heating is not working at all! until I turn the car completely off and the on again then the heating is working.

/knud
Knud, I don鈥檛 know whether this will help you but I have found a way of using HDA that works for me.

When I am driving with HDA on, I keep a slight tension on the steering wheel - as if I am trying to go a little bit to the right all the time. That does two things:

1. Stops the messages about keeping the hands on the steering wheel.
2. Makes the HDA work very smoothly indeed. You can hardly tell it is there apart from a sweeping bend.

I wasn鈥檛 really planning to use HDA when I got the car, but using it as above is actually a very relaxing way to drive on the motorway. Maybe it鈥檒l work for you.
 

Super Moderator
Ordered July 21 Yacht Blue GT Line S AWD with Heat Pump Arrived 14 May 2022
Joined
2,467 Posts
Welcome to the forum.
 

Registered
Joined
2 Posts
Hi
I got my EV6 RWD long range Yacht Blue on the 17 December and so far I satisfied with my new car, apart from a few things.
The HDA (highway driving assist) is zig zagging on the highway, it's not stable at all.
I'm I the only one that have problems with the the Pre-Heating using the 'Start Climate Control' on the KIA Connect?
When I press the button it accept [Success] Climate Control Activated, but 2 min after I get [Alarm] Climate control not available, the car is not pre heated, but even worse
when I start the car the heating is not working at all! until I turn the car completely off and the on again then the heating is working.

/knud
Hej Knud,

Just got my EV6 GT-Line - with the same issues as yours.
But according to the local Kia dealer in Odense, there is an official fix for the preheating issue.
I will have mine updated today.
Just thought I would let you know.

Brgds

Ole
 

Registered
Joined
292 Posts
Hej Knud,

Just got my EV6 GT-Line - with the same issues as yours.
But according to the local Kia dealer in Odense, there is an official fix for the preheating issue.
I will have mine updated today.
Just thought I would let you know.

Brgds

Ole
Thank you for the tip (y). Do you have a campaign code/name? I hope you鈥檒l report back when it鈥檚 done :).
 

Registered
Kia EV6 - RWD 77,4kW - Runway Red
Joined
15 Posts
Hej Knud,

Just got my EV6 GT-Line - with the same issues as yours.
But according to the local Kia dealer in Odense, there is an official fix for the preheating issue.
I will have mine updated today.
Just thought I would let you know.

Brgds

Ole
Yes let us know more asap. (y)
 

Registered
Joined
292 Posts
Hej Knud,

Just got my EV6 GT-Line - with the same issues as yours.
But according to the local Kia dealer in Odense, there is an official fix for the preheating issue.
I will have mine updated today.
Just thought I would let you know.

Brgds

Ole
I really hope we hear from you again. I talked with my dealer today, and he says there鈥檚 no campaign yet that fixes the preheating issue.
 

Registered
Joined
2 Posts
I really hope we hear from you again. I talked with my dealer today, and he says there鈥檚 no campaign yet that fixes the preheating issue.
Hi again,

When I turned the car in for the update - there was suddenly no update available - I was explained after they checked the car. Never the less, after the "check" the preheating works fine (which it didn't before) Now it's only the scheduled preheating that is still the issue.
 

Registered
Joined
292 Posts
Hi again,

When I turned the car in for the update - there was suddenly no update available - I was explained after they checked the car. Never the less, after the "check" the preheating works fine (which it didn't before) Now it's only the scheduled preheating that is still the issue.
Tak fordi du svarer tilbage*(y):).

Okay, well plugged preheating works for me too now, and scheduled doesn鈥檛 - so the same as you. I haven鈥檛 tried unplugged preheating yet, but I鈥榣l get a chance tomorrow if I remember it :unsure:.

*(to others: I said 鈥淭hank you for responding鈥 in Danish).
 
1 - 11 of 11 Posts
Top