Kia EV6 Forum banner
1 - 15 of 15 Posts

·
Registered
Kia EV6 GT Line AWD
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi all,

I picked up my new EV6 GT Line AWD (midnight black) yesterday from my local (UK) dealership. Really happy with the car itself (and slightly terrified by the acceleration!) but have had several software related issues/concerns that I'd be massively grateful for your thoughts on, please. Apologies for all the questions!

1. I'm trying to 'Activate Kia Connect' - but whenever I try it, the screen simply says 'connecting' for about 3 mins, then says 'Mobile Network Not Available - Please contact your service partner or an authorised Kia Dealer'. I've tried several times and in several locations around town (where good signal for all mobile providers), but no joy. I'll take it back in to the dealers tomorrow, but would be grateful if anyone had any insight into what the problem might be, please? Very disappointing as I can't yet connect my phone to the car to use the Kia Connect features.

2. I asked the dealership to ensure the software was updated before collection so I don't encounter any of the issues I've been reading about on the forum (eg 'Zombie mode', traction updates etc). But am struggling to find out how I would know if they have done this or not - can someone confirm how I can find out, please? I can see the 'Software Version' via Settings is still at 210719, but understand this is separate software to the main car software updates so although quite old, it is not necessarily an indication of whether the other fixes are in place. Still, even this seems to be very out of date and I believe this software also fixes some other less fundamental issues, so am a bit disappointed that they have not updated it.

3. Registering with 'My Kia' - I saw the sticker in the car that said I should register on My Kia to get the 7yr warranty, rac breakdown cover etc - but when I go through the process of registering, I get to the step where it says to add your local dealership. I can search and then see my local dealership, but it then does not let me select it - clicking the button does not do anything. I've tried on my phone and 2 different browsers on my laptop, but nada. It then won't let you go to the next step in registering without choosing a dealer, so have had to abort that too. I work in IT, so am pretty sure it's not me! Grateful if anyone else could advise if it worked for them and/or had the same issue, please?

4. I have an Android phone (Samsung Z Fold 3, which was recently updated to android 12) and was excited to be able to get Spotify working on the screen in my car ..Android Auto seems to work fine, but when I open Spotify, it just spins then says 'Spotify doesn't seem to be working at the moment'.. but then seems to start playing whatever I last played in Spotify. Oddly the Spotify app on the phone doesn't indicate it is playing anything and I had to force close the app to get it to then stop playing. I know (or am fairly certain) this is an issue with Spotify/Android, but again grateful if anyone had any insight into this and/or new how to fix, please? Spotify/android is on the latest software updates, so shouldn't be that.

Thanks
Phil
 

·
Registered
Joined
·
64 Posts
Hi all,

I picked up my new EV6 GT Line AWD (midnight black) yesterday from my local (UK) dealership. Really happy with the car itself (and slightly terrified by the acceleration!) but have had several software related issues/concerns that I'd be massively grateful for your thoughts on, please. Apologies for all the questions!

1. I'm trying to 'Activate Kia Connect' - but whenever I try it, the screen simply says 'connecting' for about 3 mins, then says 'Mobile Network Not Available - Please contact your service partner or an authorised Kia Dealer'. I've tried several times and in several locations around town (where good signal for all mobile providers), but no joy. I'll take it back in to the dealers tomorrow, but would be grateful if anyone had any insight into what the problem might be, please? Very disappointing as I can't yet connect my phone to the car to use the Kia Connect features.

2. I asked the dealership to ensure the software was updated before collection so I don't encounter any of the issues I've been reading about on the forum (eg 'Zombie mode', traction updates etc). But am struggling to find out how I would know if they have done this or not - can someone confirm how I can find out, please? I can see the 'Software Version' via Settings is still at 210719, but understand this is separate software to the main car software updates so although quite old, it is not necessarily an indication of whether the other fixes are in place. Still, even this seems to be very out of date and I believe this software also fixes some other less fundamental issues, so am a bit disappointed that they have not updated it.

3. Registering with 'My Kia' - I saw the sticker in the car that said I should register on My Kia to get the 7yr warranty, rac breakdown cover etc - but when I go through the process of registering, I get to the step where it says to add your local dealership. I can search and then see my local dealership, but it then does not let me select it - clicking the button does not do anything. I've tried on my phone and 2 different browsers on my laptop, but nada. It then won't let you go to the next step in registering without choosing a dealer, so have had to abort that too. I work in IT, so am pretty sure it's not me! Grateful if anyone else could advise if it worked for them and/or had the same issue, please?

4. I have an Android phone (Samsung Z Fold 3, which was recently updated to android 12) and was excited to be able to get Spotify working on the screen in my car ..Android Auto seems to work fine, but when I open Spotify, it just spins then says 'Spotify doesn't seem to be working at the moment'.. but then seems to start playing whatever I last played in Spotify. Oddly the Spotify app on the phone doesn't indicate it is playing anything and I had to force close the app to get it to then stop playing. I know (or am fairly certain) this is an issue with Spotify/Android, but again grateful if anyone had any insight into this and/or new how to fix, please? Spotify/android is on the latest software updates, so shouldn't be that.

Thanks
Phil
Morning Phil i'll answer where i can.

1. Kia connect requires a mobile phone signal as far as i can tell. ie the car has its own sim somewhere. That error message sounds like that is it - reason i say that is because there are other errors you can get which potentially reflect connectivity issues but this is not one I've had. I know, sounds obvious but there it is. However, do you get ANY messages from the app that relate to the car? For example, if you leave the car unlocked and walk away WITH THE KEY it very quickly(within 30 secs in my exp) alerts you, from the app, that you've left the car unlocked. However, if you've been unable to activate then i suspect not. Yes, take it to the dealer and get them to do it as it doesn't take very long. If it still doesn't work perhaps you have a fault there and you'll be in the best place to get it sorted. My local dealer is very good with this sort of thing and won't treat you like an idiot, even if you've been one :).
2.ok so i drilled down into this with my dealer. You have the correct shipping version as far as i know for UK deliveries. Yes, that software release is out of date but the Kia dealers are NOT instructed on their systems to install anything later. You can update your car yourself by downloading the update using their updater from update.kia.com. You will need a 30gig + usb stick as it's just shy of 30 gig right now so a big download. The latest update is december and will read L.001.001.211214 when installed. As far as i understand this IS the main car software version number which makes sense as the update versions below relate to navigation etc whereas this is called simply "software version". Don't be dissapointed with the dealer as they have no instruction to do this and won't randomly do things without Kia's say so, especially with a new car where they have zero experience.
3.don't know on this one but they did try to help in the dealership initially with setting this up for me and as i worked in IT i just said leave it to me and didn't realy have an issue so perhaps just go in and ask them to help.
4. Sorry i'm a carplay user with apple and have no exp with this. Spotify does work.

best of luck.
 

·
Registered
Kia EV6 GT Line AWD
Joined
·
11 Posts
Discussion Starter · #3 ·
Thanks very much, UKEV6.

Re 1. Agree that it is something car specific. It won't even let me connect the app as it says the car is not activated. I emailed the dealer yesterday then followed with a call, who told me to come in and they'll fix it. But unfortunately they had no idea when I went in (Sunday so technicians not available), so a waste of a trip - hopefully better luck when I go back tomorrow.

2. I was more concerned that they might not have applied other updates, but the manager agreed today they should have updated this software. I had requested it, so it would be nice to have some clarity either way, even if they are not officially responsible. Personally i think when it fixes actual faults, minor or not, they should be updating it on a new car.

3. Re 'My Kia'. idea in the dealership, but I've left this for now as less of a concern that this isn't working.

4. Thanks - realise this is an android/Spotify issue, will no doubt get resolved. Can't miss out on James Blunt's new release (poor topical joke)..

Annoyingly the car's alarm went off shortly after getting home today, so hope I've not got that issue too that I've seen elsewhere on the forum. Can't recall if the software updates helped with that or not.

Thanks again for making the effort to respond.
Phil
 

·
Registered
Joined
·
534 Posts
A fine choice of cars @philjg ... same as mine :) - it's GREAT isn't it?!!!

really your dealer should have helped with most of these issues at hand over. My hand over took two hours! He suggested turning off the rear seat sensors and a whole host of advice snippets.

The Nav revision can be done by you, you'll find instructions somewhere on here I'm sure, BUT there is a big update due and you might wish to just wait for that one. You'll see it on here first I'm sure. The firmware for the various modules in the car is a dealer update but they have pretty strict rules so if they have confirmed they have done them they really should have done them. There's a ABS update which I think is important. We are all waiting for the pre-conditioning update to come hopefully soon.

Dampness - just run the aircon for a few days when driving and it will dry out. Dehumidifier if you want it done now now.
 

·
Registered
Joined
·
349 Posts
Think the alarm issue may have been damp inside the cab related if I remember correctly.Think someone said they used a dehumidifier to dry it out?
Whilst anything is possible I do not think it is damp. I have had mine 3 months now and there is no damp in the car but the alarm still goes off. My dealer says it is a known problem. You can stop it happening by going to Settings/Vehicle/Convenience Alarm off. You need to do this every time you park...
 

·
Registered
Joined
·
534 Posts
Whilst anything is possible I do not think it is damp. I have had mine 3 months now and there is no damp in the car but the alarm still goes off. My dealer says it is a known problem. You can stop it happening by going to Settings/Vehicle/Convenience Alarm off. You need to do this every time you park...
wouldn't it be great to have that as an option for the spare button on the steering wheel?
 

·
Registered
Kia EV6 GT Line AWD
Joined
·
11 Posts
Discussion Starter · #11 ·
A fine choice of cars @philjg ... same as mine :) - it's GREAT isn't it?!!!

really your dealer should have helped with most of these issues at hand over. My hand over took two hours! He suggested turning off the rear seat sensors and a whole host of advice snippets.

The Nav revision can be done by you, you'll find instructions somewhere on here I'm sure, BUT there is a big update due and you might wish to just wait for that one. You'll see it on here first I'm sure. The firmware for the various modules in the car is a dealer update but they have pretty strict rules so if they have confirmed they have done them they really should have done them. There's a ABS update which I think is important. We are all waiting for the pre-conditioning update to come hopefully soon.

Dampness - just run the aircon for a few days when driving and it will dry out. Dehumidifier if you want it done now now.
Thanks Jon, it certainly is. My 3 year old boy also said 'this is a cool car', so great taste too.

To be fair to the dealer, I did say I was in a rush so didn't need a handover - wish I'd got him to try the Kia Connect activation, though, as that was the first thing on the screen.

Good tip re waiting for the big update. Hopefully with ota working too. it's not like I can even see if the remote preheating works yet anyway (my main requirement at the moment), given the activation issues.

No more alarms as of yet, so hopefully just a one-off.

Cheers
Phil
 

·
Registered
Kia EV6 GT Line AWD
Joined
·
11 Posts
Discussion Starter · #12 ·
Hi all

Just an update on point 1 (Kia Connect not activating) in case anyone else has the same issue - it's now resolved!

I found a post on kia owners club where someone suggested this can happen if the car has a long time without being able to make a connection (eg a long boat trip!) and that resetting the entertainment console (ie press the tiny button to the rhs of the volume knob - at least on a uk/rhd car - with a paperclip/pin) fixes it. And it did. It kept all my settings and immediately activated successfully.

Fully connected now from my phone, happy days.

Now on to issue 2 registering with 'My Kia'..far less important than above though.
 

·
Registered
Joined
·
64 Posts
Hi all

Just an update on point 1 (Kia Connect not activating) in case anyone else has the same issue - it's now resolved!

I found a post on kia owners club where someone suggested this can happen if the car has a long time without being able to make a connection (eg a long boat trip!) and that resetting the entertainment console (ie press the tiny button to the rhs of the volume knob - at least on a uk/rhd car - with a paperclip/pin) fixes it. And it did. It kept all my settings and immediately activated successfully.

Fully connected now from my phone, happy days.

Now on to issue 2 registering with 'My Kia'..far less important than above though.
Ah great tip thanks for posting.
 

·
Registered
Kia EV6 GT Line AWD
Joined
·
11 Posts
Discussion Starter · #14 ·
No problem

Just a quick one re another fix for no.4 (Spotify not working in Android Auto).

I followed these instructions to do a clean uninstall (deleting data/cache) and reinstalling and it is now working (hurrah).


Cheers
Phil
 

·
Registered
Joined
·
33 Posts
Thanks very much, UKEV6.

Re 1. Agree that it is something car specific. It won't even let me connect the app as it says the car is not activated. I emailed the dealer yesterday then followed with a call, who told me to come in and they'll fix it. But unfortunately they had no idea when I went in (Sunday so technicians not available), so a waste of a trip - hopefully better luck when I go back tomorrow.

2. I was more concerned that they might not have applied other updates, but the manager agreed today they should have updated this software. I had requested it, so it would be nice to have some clarity either way, even if they are not officially responsible. Personally i think when it fixes actual faults, minor or not, they should be updating it on a new car.

3. Re 'My Kia'. idea in the dealership, but I've left this for now as less of a concern that this isn't working.

4. Thanks - realise this is an android/Spotify issue, will no doubt get resolved. Can't miss out on James Blunt's new release (poor topical joke)..

Annoyingly the car's alarm went off shortly after getting home today, so hope I've not got that issue too that I've seen elsewhere on the forum. Can't recall if the software updates helped with that or not.

Thanks again for making the effort to respond.
Phil
Had the same issue with the alarm going off a random. The dealer tells me this is a known fault and a replacement motion detector is on its way.
 
1 - 15 of 15 Posts
Top