Kia EV6 Forum banner
61 - 66 of 66 Posts

·
Super Moderator
Ordered July 21 Yacht Blue GT Line S AWD with Heat Pump Arrived 14 May 2022
Joined
·
2,452 Posts
After 2 days at the dealer and showing them your reply about the amp, they are ordering the part. Hope a recall comes soon for other owners. Not impressed with KIA’s service not being able to diagnose the problem and waiting for corporate to reply to an email on how to fix the car.
Not good that there service department is not keeping up with the issues relating to the car via the bulletins sent to dealers.

You would have though the first thing they would have done when you took you car in was to check any outstanding bulletin issues on there Kia system.
 
  • Like
Reactions: Ucinn

·
Registered
Joined
·
259 Posts
got my dead amp replaced today. Everything was good at first (15 mins). The speakers in the dash then died. At lower volumes the sound system is 100% ok. All the speakers work but it I turn it up loudly with a lot of low end sound the low end in the dash shuts off. It seems it works fine at low power levels but if you create a load it seems to get hot and shut down. I have finally hit my WTF threshold. Wtf Kia
 

·
Registered
2016 Ford Edge Ti
Joined
·
276 Posts
got my dead amp replaced today. Everything was good at first (15 mins). The speakers in the dash then died. At lower volumes the sound system is 100% ok. All the speakers work but it I turn it up loudly with a lot of low end sound the low end in the dash shuts off. It seems it works fine at low power levels but if you create a load it seems to get hot and shut down. I have finally hit my WTF threshold. Wtf Kia
I bet you have! Keep us posted on what they try next to remedy this problem in your car. Has anyone else had a failure like this after an amp replacement? I hope KIA is not trying to get cute and try some other fix before actually replacing the amp.
 

·
Super Moderator
Ordered July 21 Yacht Blue GT Line S AWD with Heat Pump Arrived 14 May 2022
Joined
·
2,452 Posts
got my dead amp replaced today. Everything was good at first (15 mins). The speakers in the dash then died. At lower volumes the sound system is 100% ok. All the speakers work but it I turn it up loudly with a lot of low end sound the low end in the dash shuts off. It seems it works fine at low power levels but if you create a load it seems to get hot and shut down. I have finally hit my WTF threshold. Wtf Kia
That's not good news, sorry to read this, wonder if the amp when it failed has caused damage to the speaker or if you have another faulty amp.
 

·
Registered
Joined
·
259 Posts
AS of right now is hasnt done it again. I took it back up to the dealership, they witnessed it too. The next day it just wasn't doing it anymore. Maybe there is some software manipulation/download that went down over night. Or maybe it just hasn't been that hot again.
 

·
Super Moderator
Ordered July 21 Yacht Blue GT Line S AWD with Heat Pump Arrived 14 May 2022
Joined
·
2,452 Posts
AS of right now is hasnt done it again. I took it back up to the dealership, they witnessed it too. The next day it just wasn't doing it anymore. Maybe there is some software manipulation/download that went down over night. Or maybe it just hasn't been that hot again.
Either way whatever has happened really glad its sorted itself out for you, great news. (y)
 
61 - 66 of 66 Posts
Top