Kia EV6 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
It has been working on and off but now it only goes to level 3. Spoke to Kia Dealer service and two techs did not even know what it is. Not confident to bring it there.
Thanks, John
 

·
Registered
Joined
·
73 Posts
The answer is that it depends. If you have it set to AUTO regen, you have to hold the left paddle for a few seconds. If you are on Manual regen, just simple tap on the left paddle will put it into iPedal.
Oh and there is another thing. It doesn't work unless you are in D. Also you can't be on the brakes either.

Yeah, these hidden rules are tricky.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
The answer is that it depends. If you have it set to AUTO regen, you have to hold the left paddle for a few seconds. If you are on Manual regen, just simple tap on the left paddle will put it into iPedal.
Oh and there is another thing. It doesn't work unless you are in D. Also you can't be on the brakes either.

Yeah, these hidden rules are tricky.
Thanks and yes very tricky. Sometimes it works one way and sometimes not
 

·
Registered
22 EV6, Wind AWD/Tech Gray/Gray
Joined
·
156 Posts
Thanks and yes very tricky. Sometimes it works one way and sometimes not
You have to put it into I Pedal every time you start the car...I believe the highest number that can be 'saved' is level 3
One click of the left paddle
So I can use level 1-3 and restarting the car will keep that setting. Using IPedal will not.

AUTO mode is long Click on the right paddle to turn on and off.
 
1 - 4 of 4 Posts
Top